Autoflow - SMS Delivery Receipt Delays from Twilio to Liberty Mobile Puerto Rico – Incident details

Twilio → Carrier Networks experiencing degraded performance

SMS Delivery Receipt Delays from Twilio to Liberty Mobile Puerto Rico

Identified
Degraded performance
Started 5 days ago

Affected

Integrated Systems

Operational from 7:53 PM to 7:46 PM, Degraded performance from 7:46 PM to 12:00 AM

Twilio → Carrier Networks

Operational from 7:53 PM to 7:46 PM, Degraded performance from 7:46 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    Twilio customers may be experiencing SMS delivery receipt delays from Twilio to Liberty Mobile network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 8 hours or as soon as more information becomes available.

  • Update
    UTC
    Update

    Twilio customers may be experiencing SMS delivery receipt delays from Twilio to Liberty Mobile network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 4 hours or as soon as more information becomes available.

  • Update
    UTC
    Update

    Twilio customers may be experiencing SMS delivery receipt delays from Twilio to Liberty Mobile network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 2 hours or as soon as more information becomes available.

  • Update
    UTC
    Update

    Twilio customers may be experiencing SMS delivery receipt delays from Twilio to Liberty network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 1 hour or as soon as more information becomes available.

  • Identified
    UTC
    Identified

    Twilio customers may be experiencing SMS delivery receipt delays from Twilio to Liberty network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 24 hours or as soon as more information becomes available.